Page MenuHomePhabricator

Upgrade to newer version of puppet
Open, Needs TriagePublic

Description

Puppet 5 went eol late last year - we should upgrade

Details

Security
None

Event Timeline

We shouldn't be using puppet 5 anywhere.

macfan@bots1:~$ puppet --version
5.5.10

macfan@db1:~$ puppet --version
5.5.10

macfan@tools1:~$ puppet --version
5.5.10

macfan@mirahezebots-fhc-test2001:~$ puppet --version
5.5.10

After some testing, I discovered that puppet doesn’t fully support Debian aarch64 servers. There is an upstream ticket, but it’s set to low priority. So for now we are stuck on puppet5